Tag Archives: fix

Retro Pickup: SNES + Zelda (Non Working)

Something I’ve had langushing at the bottom of a box for a while is this old SNES.  It was given to be (free) byt a friend a while back with a copy of Zelda – A Link To The Past … Continue reading

Posted in Hardware, Restoration, retro, SNES, Teardowns | Tagged , , , , , , , , , | Leave a comment

Troubleshooting Crashing / Noisy Naomi 2 Motherboard

I recently bought a new NAOMI 2 motherboard to replace the one I currently have that only plays Naomi 1 games (I dropped it and one of the GPUs de-socketed itself).  This board was sold as working and, well, it … Continue reading

Posted in Arcade Hardware, Hardware, Repair, Teardowns, Troubleshooting | Tagged , , , , , , , , | Leave a comment

Monitor Update 2 – Fixed!

Thanks to some lovley people on the internet I have works around the issue with my Ms2930 and it’s now back to full working order again!  The problem?  The third dip switch on the remote board is faulty.  Why did … Continue reading

Posted in Arcade Hardware, Hardware | Tagged , , , , , | Leave a comment

Monitor Update 1 – It MIGHT Not Be All That Bad…

There are some great people over on the Arcade Otaku forums. Had a chat with a knowledgeable chap who gave me some pointers as to the three most common issues I can check myself that could cause the monitor to … Continue reading

Posted in Arcade Hardware, General, Hardware | Tagged , , , , , , | Leave a comment

Yin and Yang

Well I manage to strike it lucky on eBay and get a “probably working” Sega Titan ST-V system with two games (Die Hard Arcade and Winter Heat) for a great price.  Awesome!  On the flip side  I now, for some … Continue reading

Posted on by | Tagged , , , , , | Leave a comment

Marquee Light Now Working (Confirmed “390-5638-1E” == FG-1E)

The starter ballast arrived today in the form of the FG-1E florescent tube Glow Lamp that I hope is a direct replacement for the Sega part “390-5638-1E” mentioned in the back of the Blast City manual. As you can see … Continue reading

Posted in Arcade Hardware, Hardware, Uncategorized | Tagged , , , , , , , , , | Leave a comment

Getting The Marquee Light Working Again (tracking down odd starter ballasts)

When I got the cab one of the few things I knew didn’t work at all (possibly the only thing that was actually faulty) was the marquee light.  Not the “Vs” display or the “Winner” lights, those are fine.  It’s … Continue reading

Posted in Arcade Hardware, General, Hardware | Tagged , , , , , , , | Leave a comment